Bezzera Ellisse Electric Wiring Diagram Schematic

Bezzera Wiring Diagram

Bezzera Wiring Diagram

This entry was posted in Uncategorized. Bookmark the permalink.

7 Responses to Bezzera Ellisse Electric Wiring Diagram Schematic

  1. Simon Talbot says:

    Hi, could you advise if the terminals are bridged, I am somewhat confused 🙂 I know this is simple, but driving me insane.
    I have a thin blue wire and thin brown wire, these were bridged in on the old element, these wires come from the main power box on the front of the machine.
    I then have the 3 thick cables (Blue Brown & black) that come up from the thermal cut out at the bottom of the machine.
    On the element I have 4 poles that feed the positive and negative of the element, the element has 2 x coils, the bottom one being smaller.
    I guess what I am asking is where do the wires go on this new element and should they be bridged.
    If I attach thick blue (-) to top left and thick brown (+) top right that will power only the top coil of the element.
    Then thin blue (-) bottom left & thin brown (+) bottom right, I am then left with a spare thick black (from thermal cut out below).

    I am thinking I should be bridging, left top Thin blue, left bottom thick blue, but bridged together with a loop wire.
    Then right top – Thick brown & thick black with thin brown on bottom, again bridged together with loop wire.

    Its a shame your photo’s have all the wires covered with heat shield otherwise I would be able to see from there.

    Last thing that does not look quiet right to me, so I will mention it… When checking the thermal cut out wiring, I would assume that the poles are straight through, i.e. 3 wires in and 3 wires out with the poles being switched across, i.e. black in black out. On mine it would appear that the brown & black may have been swapped element side as assuming they break straight across the cut out I have blue opposite blue, but brown opposite black and black opposite brown?

    If you can help, I would appreciate it, kind regards,

    Simon.

    • Simon Talbot says:

      Hi, just realized the thin wires, just feed the lights at the front of the machine, so guess these get piggy backed, so no issues there. Still not clear the rest though, I am now thinking that at times only part of the element should be energized, so bridging together would stop that.

      Should the element operate all on or all off only? or should the top of the element work independently from the bottom?

      thanks,

  2. admin says:

    Looking at the diagram, which is all I have to go on as I don’t have the machine any more, there appear to be 6 connections to the coils in total.

    Both elements appear to work at the same time.

    The contactor has two outputs, which are from the same input, so these are two identical feeds of Neutral, taken from separate contacts for reliability. I guess if one contact fails to close, you still have one element working, so can make coffee !

    The safety thermostat and the pressure switch provide two similar feeds of live.

    The lamp is connected across one of the elements.

    Element 1: one side Neutral in + lamp out, other side live in+lamp out
    Element 2: one side Neutral in, other side live in

  3. Omar says:

    Hi, I came today to see an Ellisse PM 3GR, no hot water or steam and found the pressure switch is not activating, when disconnected the pressure switch pipe from the tank I found no water came out, so is not filling, what could be the problem.
    If you can help, I would appreciate it, kind regards,

    • admin says:

      Hi,

      I don’t know that machine.

      More information required:

      Is it a new install?
      Is the water on?
      Has the pump been hear to run?
      Has the pump stopped running recently?
      What is the water level in the tank?
      If you short the probe to the boiler does the heater come on?
      Does the inlet operate, if the machine has one?
      Is the pump jammed?
      etc….

      Steve.

      • Omar says:

        Hi Steve, thanks for your reply, the answers:
        It is not a new install.
        The pump runs and stops.
        Water level is very low
        The machine was working that morning and stopped few hours later, does the pump run when filling the machine or only the solenoid valve.
        I think the inlet is not operating
        What to look for….thanks

        • admin says:

          As I say, I don’t know the machine model.

          I would have thought the pump should run when topping up the boiler.

          I would check the water feed is on. The inlet solenoid works and that the pump is not jammed.

Leave a Reply

Your email address will not be published. Required fields are marked *